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Introduction to the network scan driver
The network scan driver provides a SANE (Scanner Access Now Easy) interface to allow scanning from a network-based
printer.

Installing the network scan driver
System requirements
Before installing the network scan driver, make sure:

•
•
•
•
•

You are logged in with root user authority.
You have 62MB of free disk space for a complete installation.
You have SANE and/or SANE back ends installed on your server.
Your computer is properly configured to communicate with a supported network printer over TCP/IP.
Your printer has an internal network card and can communicate through an IPv4 network. External network adapters
are not supported.

Supported operating systems
Make sure you are running any of the following Linux distributions:

•
•
•
•
•
•
•
•
•

Debian GNU/Linux
Fedora
Linpus Linux Desktop
Linux Mint
Linux openSUSE
Linux SUSE Enterprise Desktop
Red Flag Linux Desktop
Red Hat Enterprise Linux WS
Ubuntu Linux

Note: For specific supported operating system versions, see the the Web site for your operating system, or see the file
supported-platforms.txt in the path /usr/lexscan/docs/ after installation.

Installing on Fedora, Linpus Linux, SUSE Linux, Linux openSUSE, Red Hat Enterprise
Linux, or Red Flag Linux
1 Download the driver:
a Go to www.lexmark.com.
b Select Driver Finder from the Drivers & Downloads list.
c Select the Linux distribution running on your computer.
d Select network-scan-linux-glibc2-x86.rpm, and then download it to your computer.
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2 Do either of the following:
• Double-click the package file.
• On a terminal window, type the following, and then press Enter:
rpm -ivh network-scan-linux-glibc2-x86.rpm

Installing on Debian GNU/Linux or Ubuntu Linux
1 Download the driver:
a Go to www.lexmark.com.
b Select Driver Finder from the Drivers & Downloads drop-down list.
c Select the Linux distribution running on your computer.
d Select network-scan-linux-glibc2-x86.deb, and then download it to your computer.
2 Do either of the following:
• Double-click the package file.
• On a terminal window, type the following, and then press Enter:
dpkg -i network-scan-linux-glibc2-x86.deb

Checking if the network scan driver is installed
Make sure that the installed network scan driver is added to the dll.conf file, and that the device file is present.
To list the currently available devices, type scanimage -L on a terminal window, and then press Enter.
A message indicating that your device is found appears on your computer.

Scanning using a network printer
1 Open a SANE-compliant application, such as XSane or scanadf.
2 Select the network printer and the settings you want.
3 Load the document into the Automatic Document Feeder (ADF) or on the scanner glass.
4 From the printer control panel, select your profile.
For more information, see the printer User's Guide.

Removing the network scan driver
1 Do the following, depending on your operating system:

In Fedora, Linpus Linux, SUSE Linux, Linux openSUSE, Red Hat Enterprise Linux,
or Red Flag Linux
On a terminal window, type the following, and then press Enter:
rpm -e lexmark-network-scan
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In Debian GNU/Linux or Linspire Linux
On a terminal window, type the following, and then press Enter:
dpkg -r lexmark-network-scan

2 Remove the lexmark_nscan entry from the /etc/sane.d/dll.conf file.

Introduction to the network scan driver
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Scanning
For more information on selecting a scan job from the printer control panel, see the printer User's Guide.

Scanning using applications
Scanning using XSane
1 On a terminal window, type xsane, and then press Enter.
2 From the “device detection” dialog, navigate to:
Available devices > select your printer > OK

3 From the main dialog, click Window > Show standard options.
4 If necessary, adjust other scan settings.
5 From the main dialog, click Scan.
6 Load the document into the Automatic Document Feeder (ADF) or on the scanner glass.
7 From the printer control panel, select your scan job.

Scanning using OpenOffice.org
Note: You may use Writer, Impress, or Draw only.

1 From an OpenOffice.org application toolbar, do either of the following:
• Click Insert > Picture > Scan > Select Source.
• Click Insert > Graphics > Scan > Select Source.
2 From the “Device Used” menu, select your printer, and then click OK.
3 Repeat step 1 to confirm if the correct printer is selected.
4 Select your options, and then click OK.
5 From the application toolbar, do either of the following:
• Click Insert > Picture > Scan > Request.
• Click Insert > Graphics > Scan > Request.
6 Load the document into the ADF or on the scanner glass.
7 From the printer control panel, select your scan job.
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Scanning using GIMP
GNU Image Manipulation Program (GIMP) is the standard paint program for UNIX/Linux systems. It supports scanning
by using existing scanning tools (xscanimage and XSane) used as plug-ins. The GIMP plug-in function allows xscanimage
and XSane to provide the scanned image to GIMP.
Note: Make sure the GIMP plug-in that came with your operating system is installed.

1 Launch GIMP.
2 From the toolbar, do either of the following:
• Click File > Acquire > XSane: Device dialog.
• Click File > Acquire > xscanimage: Device dialog.
3 From the “device detection” dialog, navigate to:
Available devices > select your printer > OK

4 From the dialog, if necessary, adjust other scan settings, and then click Scan.
5 Load the document into the ADF or on the scanner glass.
6 From the printer control panel, select your scan job.

Scanning using a terminal window
1 On a terminal window, type the following, and then press Enter:
scanimage -d [device_name] > /tmp/scan.pnm

2 If necessary, adjust the scan settings.
3 Load the document into the ADF or on the scanner glass.
4 From the printer control panel, select your scan job.
Note: If an Assertion 'c->xlib.lock' failed error occurs when using openSUSE 10.3, refer to
http://en.opensuse.org/Xlib.lock for troubleshooting information.

Scanning multiple pages
The default paper source for scanning is the Automatic Document Feeder (ADF). If there are no documents loaded in
the ADF, then the printer scans from the scanner glass.
You can scan multiple pages in several ways depending on the application.

Using scanimage
1 On a terminal window, type the following, and then press Enter:
scanimage -b --source=”Multiple Pages” -d [device_name]

2 Load the document into the ADF or on the scanner glass.
3 From the printer control panel, select your scan job.
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Using scanadf
1 On a terminal window, type the following, and then press Enter:
scanadf --source=”Multiple Pages” -d [device_name]

2 Load the document into the ADF or on the scanner glass.
3 From the printer control panel, select your scan job.

Using OpenOffice.org
Note: You may use Writer, Impress, or Draw only.

1 From an OpenOffice.org application toolbar, do either of the following:
• Click Insert > Picture > Scan > Select Source.
• Click Insert > Graphics > Scan > Select Source.
2 From the “Device Used” menu, select your printer, and then click OK.
3 Repeat step 1 to confirm if the correct printer is selected.
4 From the “Options” area, click Image Settings > source.
5 From the “source” menu, select Multiple Pages.
6 Click OK.
7 From an OpenOffice.org application toolbar, do either of the following:
• Click Insert > Picture > Scan > Request.
• Click Insert > Graphics > Scan > Request.
8 From the printer control panel, select your scan job.
9 Repeat step 6 until all the pages of your document are displayed on your computer.

Using XSane
1 On a terminal window, then type xsane, and then press Enter.
2 From the “device detection” dialog, navigate to:
Available devices > select your printer > OK

3 From the

menu, select Multiple Pages.

4 Click Scan.
5 Load the document into the ADF or on the scanner glass.
6 From the printer control panel, select your scan job.
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Using XSane version 0.99 or later
1 From the

menu, select Multiple Pages.

2 Click Scan.
If you specify a number that is smaller than the number of pages loaded in the ADF, then only the number of pages
specified are scanned.
You have to click Scan again to scan the remaining pages.

3 Load the document into the ADF or on the scanner glass.
4 From the printer control panel, select your scan job.

Using XSane versions earlier than 0.99
1 From the toolbar, navigate to:
Preferences > Setup > select Enhancement tab > Scan Multiple Page

2 From the dialog, click Scan.
3 Load the document into the ADF or on the scanner glass.
4 From the printer control panel, select your scan job.
5 Repeat step 2 until all the pages of your document are displayed on your computer.

Scanning both sides of a page
Notes:

• Make sure that your printer has a duplex scanner and an Automatic Document Feeder (ADF).
• Make sure you load the document into the ADF.
• The duplex scanner and ADF are available only in select models.
You can scan both sides of the page in several ways depending on the application.

Using scanimage
1 On a terminal window, type the following, and then press Enter:
scanimage -b --scan-both-sides=yes -d [device_name]

2 Load the document into the ADF.
3 From the printer control panel, select your scan job.

Using scanadf
1 On a terminal window, type the following, and then press Enter:
scanadf --scan-both-sides=yes -d [device_name]

2 Load the document into the ADF.
3 From the printer control panel, select your scan job.
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Using OpenOffice.org
Note: You may use Writer, Impress, or Draw only.

1 From an OpenOffice.org application toolbar, do either of the following:
• Click Insert > Picture > Scan > Select Source.
• Click Insert > Graphics > Scan > Select Source.
2 From the “Device Used” menu, select your printer, and then click OK.
3 Repeat step 1 to confirm if the correct printer is selected.
4 From the “Options” area, click Image Settings > source.
5 From the “source” menu, select Multiple Pages.
6 From the “Options” area, click Image Settings > scan-both-sides.
7 Select the scan-both-sides check box, and then click OK.
8 From the application toolbar, do either of the following:
• Click Insert > Picture > Scan > Request.
• Click Insert > Graphics > Scan > Request.
9 Load the document into the ADF.
10 From the printer control panel, select your scan job.
11 Repeat steps 8 through 10 until all the pages of your document are displayed on your computer.

Using XSane
1 On a terminal window, type xsane, and then press Enter.
2 From the “device detection” dialog, navigate to:
Available devices > select your printer > OK

3 From the

menu, select Multiple Pages.

4 From the toolbar, click Window > Show standard options.
5 Select the Scan both sides check box.
6 From the main dialog, click Scan.
7 Load the document into the ADF.
8 From the printer control panel, select your scan job.

Canceling a scan
To cancel a scan, do one of the following:

• From the dialog displayed after you send a scan job to the network printer, click Cancel Scan Profile > Yes.
• Close the application.
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• Cancel the scan job:
1 From the printer control panel, cancel the scan job.
2 Cancel the scan from the dialog displayed after you send a scan job to the network printer.
For more information, see the printer User's Guide.

Adjusting scan settings
Adjusting scan settings using XSane or OpenOffice.org
Depending on the application, do either of the following to access the scan options:

• Using XSane
1 On a terminal window, type xsane, and then press Enter.
2 From the “device detection” dialog, navigate to:
Available devices > select your printer > OK

3 From the main dialog, do either of the following:
– Click Window > Show standard options.
– Click Window > Show advanced options.
• Using OpenOffice.org
Note: You may use Writer, Impress, or Draw only.

1 From an OpenOffice.org application toolbar, do either of the following:
– Click Insert > Picture > Scan > Select Source.
– Click Insert > Graphics > Scan > Select Source.
2 From the “Device Used” menu, select your printer, and then click OK.
3 Repeat step 1 to confirm if the correct printer is selected.
4 From the “Options” area, select Image Settings or Advanced Settings.
Use

To

Content Type or content-type

Select the document type.

or scan-resolution

Select a scan resolution.
Resolutions for all the printers are displayed as options. Make
sure the printer supports the resolution you select.
Note: The

or mode

Select a color depth.
Note: The

Original Size or original-size

icon is found on the XSane main dialog.
is found on the XSane main dialog.

Select a document size.
Document sizes for all the printers are displayed as options.
Make sure the printer supports the size you select.
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Use

To

Scan both sides or scan-both-sides

Perform a duplex scan.
Notes:

• Make sure that the printer has a duplex scanner and an
Automatic Document Feeder (ADF).

• Make sure to load the document into the ADF.
• The duplex scanner and the ADF are available only in
select models.
orientation or Orientation

Select a portrait or landscape orientation.
Select a brightness setting.

or brightness

Note: The

icon is found on the XSane main dialog.

Select a contrast setting.

or contrast

Note: The
or source

icon is found on the XSane main dialog.

Scan a single-sheet or a multiple-page document.
Note: The

icon is found on the XSane main dialog.

Invert pixel values.

or Invert pixel values

Note: The
Background Removal

icon is found on the XSane main dialog.

Remove smudges and light background shading when
scanning color documents.
Note: Background Removal is available only in XSane.

Color Dropout

Select a color to remove.
Note: Color Dropout is available only in XSane.

Color Dropout Threshold

Select a color dropout quality.
Note: Color Dropout Threshold is available only in XSane.

Mirror Image

Produce a mirror image of the document.
Note: Mirror Image is available only in XSane.

Note: Your printer may not support all the options. For more information, see the printer User's Guide.

Adjusting scan settings using scanimage
Some of these values may not be available, depending on the printer you purchased.
Scanimage is a command-line-only application that uses the first scanner found and the default scan settings. A
command initiates the scan and stores the image in TIFF or PXM format. You can provide command-line options to
specify the scan settings.
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For example, to initiate scanning of a legal-size document, type scanimage original-size=Legal
> /tmp/image.pxm in the command line, and then press Enter.
To

Type

Values

Specify the printer

-d [device_name]

[device_name]

Select the document type

content-type

Text
Text/Graphics
Photo

Select a scan resolution

scan-resolution

75
100

Note: Resolutions for all the printers
are displayed as options.

150
200
300
400
600
1200
Note: Make sure the printer supports
the resolution you select.

Select a color depth

mode

1-bit Black & White
8-bit Grayscale
24-bit Color
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To

Type

Values

Specify the document size

original-size

Letter
Executive

Note: Document sizes for all the
printers are displayed as options.

Legal
A3
A4
A5
A6
B4
B5
Tabloid
Oficio (Mexico)
Folio
Statement
Universal
Custom Scan Size
ID Card
3x5 Photo
4x6 Photo
Business Card
Book Original
Auto Size
Mixed Size
3x5 in
3.5x5 in
4x6 in
4x8 in
5x7 in
8x10 in
9x13 cm
10x15 cm
10x20 cm
13x18 cm
20x25 cm
L
2L
Hagaki
Note: Make sure the printer supports
the size you select.
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To

Type

Values

Specify the document being scanned document-source

Black and White Laser
Color Laser
Inkjet Plain
Inkjet Glossy
Retail Photo
Photo
Magazine
Newspaper
Press
Notes:

• Make sure the printer supports
the size you select.

• The printer uses the default
values if the option is not
supported.
Perform a duplex scan

scan-both-sides

no
yes
Notes:

• Make sure your printer has a
duplex scanner and an Automatic
Document Feeder (ADF).

• Make sure to load the document
into the ADF.

• The duplex scanner and ADF are
available only in select models.
Select a portrait or landscape
orientation

orientation

Select a brightness setting

brightness

1–9

Select a contrast setting

contrast

0–5

portrait
landscape

Scan a single-sheet or multiple-page source
document

Single Page

Invert pixel values

no

Multiple Pages

negative-image

yes
Remove smudges and light
background shading when scanning
color documents

background-removal

-4–+4

Specify a color to remove

color-dropout

None
Red
Green
Blue

Select a color dropout quality

color-dropout-threshold
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0–254

To

Type

Values

Produce a mirror image of the
document

mirror-image

no
yes

Notes:

• To get a list of supported options, you can also type scanimage --help.
• Your printer may not support all these options. For more information, see the printer User's Guide.

Setting default scan options
All default scan options are stored in the scan driver configuration file, /etc/sane.d/lexmark_nscan.conf. Changing the
values in the scan driver configuration file changes the default settings. The settings are reflected in the application.
XSane stores the most recently used scan settings in the ${HOME}/.sane/xsane directory. In order for XSane to reflect
the changes you made in the scan driver configuration file, do the following:

1 Close XSane in the application.
2 On a terminal window, type the following, and then press Enter:
rm -f ${HOME}/.sane/xsane/*.drc

3 Type xsane, and then press Enter

Scanning
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Troubleshooting
Printer scans the page, but image is not displayed on the
computer
Make sure that the IP address of your computer matches the IP address assigned to your network interface card.

1 On a terminal window, type hostname, and then press Enter.
2 Type the following, and then press Enter:
ping [computer_hostname]
Take note of the IP address listed.

3 Type the following, and then press Enter:
/usr/lexscan/bin/lsinet
Compare the IP address listed with the IP address obtained in step 2.
If the IP addresses do not match, then do one the following:

• Correct your /etc/hosts or DNS entries.
• Update the SANE driver configuration file and specify the appropriate network interface to use.
For more information on how to correct /etc/hosts or DNS entries, see the documentation that came with your operating
system.
If the problem is not resolved, then see “Printer stops scanning or prints a 'Profile scan failed' page” on page 19.

Printer stops scanning or prints a “Profile scan failed” page
DISABLE ANY FIREWALL APPLICATION
To disable your firewall application, see the documentation that came with your operating system.

OPEN THE REQUIRED SCANNING PORTS (TCP: 9751-9760)
On a terminal window, type the following, and then press Enter:
# iptables -I INPUT -p tcp --dport 9751:9760 -j ACCEPT -i eth0
For most Linux distributions, you can open specific ports with the iptables command.

ACCEPT THE DEVICE CERTIFICATE
If there is an error verifying a security certificate before completing a scan, then accept the certificate to proceed.
You may accept the certificate for a single scan job or for all future scan jobs.
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ENTER A VALID SCAN JOB LOGIN
If 401 Unauthorized Error appears when sending a scan job to the printer, then you need to provide a valid
user name and password.
The user name and password combination is valid for a single scan job and all future scan jobs.

Only one page is displayed on the computer
Make sure the source is set to Multiple Pages.

IF USING AN OPENOFFICE.ORG APPLICATION
You may use Writer, Impress, or Draw only.

1 From an OpenOffice.org application toolbar, do either of the following:
• Click Insert > Picture > Scan > Select Source.
• Click Insert > Graphics > Scan > Select Source.
2 From the “Options” area, click Image Settings > source.
3 From the “source” menu, select Multiple Pages.
4 Click OK.

IF USING XSANE
1 From the

menu, select Multiple Pages.

2 Click Scan.

IF USING SCANADF
On a terminal window, type the following, and then press Enter:
scanadf --source=”Multiple Pages” -d [device_name]

IF USING SCANIMAGE
On a terminal window, type the following, and then press Enter:
scanimage -b --source=”Multiple Pages” -d [device_name]

Printer not compatible
Make sure:

• Your printer is a multifunction printer.
• The network scan driver supports your printer.
For more information on your printer's compatibility, see the printer User's Guide.
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SANE does not recognize the network scan driver
SANE-compliant applications such as XSane and scanadf access the printer through SANE.
Make sure:

•
•
•
•
•
•

The scan driver is installed in the /usr/lib/sane directory.
The scan driver device file exists.
The scan driver is listed in the /etc/sane.d/dll.conf file.
“lexmark_nscan” is listed in the /etc/sane.d/dll.conf file and no “#” is typed before it.
The SANE installation is using the directory structure /usr/lib/sane and /etc/sane.d/.
For some SANE installations, you may need to set the LD_LIBRARY_PATH:
On a terminal window, type the following, and then press Enter:
export LD_LIBRARY_PATH=/usr/lib

XSane displays garbage characters
Run XSane version 0.90 or later, which supports more languages than earlier versions.
Note: If you are running Linpus Linux, then upgrade XSane to version 0.90 or later so it will work correctly with
non-English languages.
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